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Preface 

The National Curriculum Framework, 2005, recommends that children’s life at 
school must be linked to their life outside the school. This principle makes a 

departure from the legacy of bookish learning which continues to shape our 

system and causes a gap between the school, home, community and the 

workplace. 

The student workbook on “Spreadsheet (Intermediate)” is a part of the 
qualification package developed for the implementation of National Vocational 

Education Qualification Framework (NVEQF), an initiative of Ministry of Human 

Resource Development (MHRD), Government of India to set common principles 

and guidelines for a nationally recognized qualification system covering 

Schools, Vocational Education and Training Institutions, Technical Education 

Institutions, Colleges and Universities. It is envisaged that the NVEQF will 

promote transparency of qualifications, cross-sectoral learning, student-

centred learning and facilitate learner’s mobility between different 
qualifications, thus encouraging lifelong learning. 

This student workbook, which forms a part of vocational qualification package 

for student’s who have passed Class IX or equivalent examination, was created 

by a group of experts. The IT-ITeS Skill Development Council approved by the 

National Skill Development Corporation (NSDC) for the IT/ITeS Industry 

developed the National Occupation Standards (NOS). The National Occupation 

Standards are a set of competency standards and guidelines endorsed by the 

representatives of IT Industry for recognizing and assessing skills and knowledge 

needed to perform effectively in the workplace. 

The Pandit Sunderlal Sharma Central Institute of Vocational Education 

(PSSCIVE), a constituent of National Council of Educational Research and 

Training (NCERT) in association with Wadhwani Foundation has developed 

modular curricula and learning materials (Units) for the vocational qualification 

package in IT/ITes sector for NVEQ levels 1 to 4; level 1 is equivalent to Class 

IX. Based on NOS, occupation related core competencies (knowledge, skills, and 

abilities) were identified for development of curricula and learning modules 

(Units). 

This student workbook attempts to discourage rote learning and to bring about 

necessary flexibility in offering of courses, necessary for breaking the sharp 

boundaries between different subject areas. The workbook attempts to 

enhance these endeavours by giving higher priority and space to opportunities 

for contemplation and wondering, discussion in small groups and activities 

requiring hands-on-experience. We hope these measures will take us 
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significantly further in the direction of a child-centred system of education 

outlined in the National Policy of Education (1986). The success of this effort 

depends on the steps that school Principals and Teachers will take to encourage 

children to reflect their own learning and to pursue imaginative and on-the-job 

activities and questions. Participation of learners in skill development exercises 

and inculcation of values and creativity is possible if we involve children as 

participants in learning, and not as receiver of information. These aims imply 

considerable change in school routines and mode of functioning. Flexibility in 

the daily time-table would be a necessity to maintain the rigour in 

implementing the activities and the required number of teaching days will have 

to be increased for teaching and training. 
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About Your Workbook 

This workbook is to assist you with completing the Unit of Competency IT204-
NQ2012: Spreadsheet (Intermediate). You should work through the workbook 
in the classroom, at the workplace or in your own time under the guidance and 
supervision of your teacher or trainer. 

This workbook contains sessions which will help you to acquire relevant 
knowledge and skills (soft and hard) on various aspects of the unit of 
competency. Each session is small enough to be easily tackled and digested by 
you before you move on to the next session. Animated pictures and 
photographs have been included to bring about visual appeal and to make the 
text lively and interactive for you. You can also try to create your own 
illustrations using your imagination or taking the help of your teacher. Let us 
now see what the sections in the sessions have for you. 

Section1: Introduction 

This section introduces you to the topic of the Unit. It also tells you what you 
will learn through the various sessions covered in the Unit. 

Section 2: Relevant Knowledge 

This section provides you with the relevant information on the topic (s) covered 
in the session. The knowledge developed through this section will enable you to 
perform certain activities. You should read through the information to develop 
an understanding on the various aspects of the topic before you complete the 
exercise (s). 

Section 3: Exercise 

Each session has exercises, which you should complete on time. You will 
perform the activities in the classroom, at home or at the workplace. The 
activities included in this section will help you to develop necessary knowledge, 
skills and attitude that you need for becoming competent in performing the 
tasks at workplace. The activities should be done under the supervision of your 
teacher or trainer who will guide you in completing the tasks and also provide 
feedback to you for improving your performance. To achieve this, prepare a 
timetable in consultation with your teacher or trainer and strictly adhere to the 
stipulated norms or standards. Do not hesitate to ask your teacher or trainer to 
explain anything that you do not understand. 

Section 4: Assessment 

The review questions included in this section will help you to check your 
progress. You must be able to answer all the questions before you proceed to 
the next session. 
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SESSION 1: USE AUTOSUM IN CELLS 

RELEVANT KNOWLEDGE 

You have learnt to navigate in a spreadsheet, populate cells, and perform calculations. 

As you know, a spread sheet offers various mathematical functions to perform the 

calculations. Sum is one of the functions available in the spread sheet to perform 

addition of selected numbers in the sheet. In this exercise, you will learn how to use 

autosum function to perform addition in a spread sheet. 

Autosum is used for adding the values given in cells automatically without writing the 

formula to perform the operation. 

Open a new spread sheet and enter the following data. 

Figure 1 

Now to total the marks of each of the students, do the following: 

	 Go to cell G2. While the cell G2 is selected, click on the AutoSum option 

available under Editing Group in the Home tab. 

AutoSum 

Figure 2 

	 The values in the cells from c2 to f2 will be automatically selected as shown 

below. 
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Figure 3 

 Press Enter. 

o The total marks of Abhas appears in cell G3. 

o Similarly, calculate the total marks of the rest of the students. 

Figure 4 

Note: Autosum automatically selects the values around the cells either horizontally or 

vertically. In the above example you want to perform addition of numbers listed from 

left to right, after finding the total of two persons when you try to perform autosum 

for another person the values on top of the current cell get selected. In that case, you 

have to select the cell values that you want to perform addition. 

Now change the marks of one of the students in one or more subjects. The total marks 

of that student will get calculated automatically. Automatic calculation of formulas is 

one of the most powerful features of electronic spreadsheets. 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Calculate without writing the formulae using the Autosum function 

2. Create a list of all your personal expenses made during the month and 
calculate the total expenses using the autosum function 

3. Create a list of names of the month and holidays in that month. Add 
and calculate the total number of holidays in a year using the 
autosum function 
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ASSESSMENT 

Fill in the blanks 

1. 	____________ _________________of formulas is one of the most 

powerful features of electronic spreadsheets. 

2. 	________________ is used for adding the values given in cells 

automatically without writing the formula. 

3. 	AutoSum option is available in _________________ group under the 

Home tab. 

4. 	Autosum automatically selects the values around the cells either 

_____________ or ______________. 
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SESSION 2: CONDITIONAL FORMATTING 

RELEVANT KNOWLEDGE 

Conditional formatting allows you to change the formatting (font color, border, 

shading) of the cells based on the values in it. Yes, you can do that manually, but it 

can be a tiresome task if you have a huge amount of data. So, you specify a condition 

for the values in the cell, and if the condition is satisfied then automatically the 

formatting of the cell changes. This feature would be very useful if you were working 

on a profit and loss spreadsheet, or a temperature variance spreadsheet, or a 

marksheet. You could highlight cells that have values are greater than a defined rule 

with one color and those less than another with a different color. 

Basically, you can select one or more cells, and create rules (conditions) for when and 

how those cells are formatted. The conditions can be, based on the selected cell's 

contents, or based on the contents of another cell. 

You can control the following formats: 

 Number format 

 Font, font style, and font colour (but not font size) 

 Fill colour and fill pattern 

 Border colour and border style (but not border thickness) 

Open a new spreadsheet and enter the following data. 

Figure 5 

Now to apply conditional formatting for the data do the following. 

 Select all the cells you want to format conditionally. 

Figure 6 
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 Click on Conditional Formatting option available under Styles group in the 

Home tab. A drop down list appears. 

Figure 7 

Click on Highlight Cells Rules option, a submenu appears. 

	 Note: you can select the condition listed according to your needs. In this 

example if you want to highlight the values that are greater than 75, select 

“Greater Than...” available under the submenu. A dialog box appears. 

Figure 8 

	 Specify the value in the box and click on the down arrow next to the with field 

and select a predefined format for the condition from the drop down list. If you 

want to highlight the cell contents with your own formatting style click Custom 

Format option in the dropdown list. 

	 A Format Cells dialog box appears. You can select a different font color under 

Font tab, border style and color under Border tab and fill color under Fill tab. 

	 Go ahead and create the data below and format it in the manner displayed. 

Figure 9 
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Note: Similarly you can set various conditions for the selected value like less than, 

equal to, between etc. 

Optionally, you can also specify the cell address where the value is stored. This can be 

very helpful as simply changing the value in one place can change the conditional 

formatting all over the previously selected range. An example is shown in the figure 

below. 

Figure 10 

The result is displayed below. 

Figure 11 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Perform conditional formatting on a data subset 

2. 
Create a student mark list of at least 10 students and five subjects. 

Highlight the marks of the students who got marks greater than 80 

with green colored text with blue fill. Save the worksheet as 

Marks_{your name}. 

13 



ASSESSMENT 

Fill in the blanks 

1. 	_________________conditional formatting allows you to change the 

formatting (font color, border, shading) of the cells based on the values 

in it. 

2. 	Conditional formatting is available under _______________ Styles group 

in Home tab. 

Answer the following: 

1. 	List any five conditions/formats/items that can be used for conditional 

formatting. 
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SESSION 3: HIDE / UNHIDE / FREEZE ROWS AND COLUMNS 

RELEVANT KNOWLEDGE 

Sometimes you have data in rows and columns which are needed for formulas or 

charts, but you do not want the data to be visible. A very handy feature of a 

spreadsheet is the ability to hide a row/column that is not to be shown to the end 

user. The data in hidden row/column is available for calculations though not visible! 

Freezing rows and columns is another helpful feature in a spreadsheet. When you are 

dealing with a huge amount of data that spans several rows or columns, you may want 

the headers to remain constant (frozen) while you scroll through the data so that you 

can see the identifying names of the rows/columns. 

Open a new spreadsheet. To hide a row or column, do the following: 

 In order to hide any row or column you can either select the particular row or 

column that is to hidden or just one cell in the corresponding row or column 

(for example B3). 

 Click on Format option available under Cells group in the Home tab. 

Format 

Figure 12 

 A dropdown list appears as shown below. 

Figure 13 
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	 Click on Hide & Unhide > Hide Rows. The spread sheet will be displayed as 

shown below. 

Note: Alternatively, you can select the row/column, right click and select Hide. 

Figure 14 

Note: In this example the cell in the 3rd row of the spread sheet was selected and then 

Hide Rows option was selected. So, the 3rd row is hidden. What would have happened 

if you had selected Hide Columns instead? 

	 In order to unhide the row or column that is hidden you have to select any cells 

before and after the cell that is hidden then click Unhide Rows in the Format 

option available under Home tab. 

To freeze the rows or columns do the following. 

 Open a new spread sheet. 

 In order to freeze rows or columns click on Freeze Panes option available 

under Window group in View tab. 

	 A drop down list appears as shown below. Click on Freeze Panes. Doing so will 

freeze all the rows above and all the columns to the left of the selected cell. Scroll 

your mouse in the spreadsheet the frozen rows and columns remain constant. 

Figure 15 

Note: The panes are formed where your cursor is placed. Select the option again and 

notice the change in the available options! Go ahead and try the other options too. 

You can also freeze the entire row or column by selecting the entire row or column 

and click “Freeze Panes” to freeze the entire row or column. 
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EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Hide/unhide rows/columns 

2. Freeze/unfreeze rows/columns 

Create the worksheet given below, keeping your cursor on B2, try all the 

options of freezing cells and observe the effect. Take specific note of 

column and row movements. Save the worksheet as expenses_{your name}. 

ASSESSMENT 

Fill in the blanks: 

1. When you freeze a row, ____________ remains constant. 

2. Freeze Panes option is available under _________ group in ________ tab. 

3. The panes are formed where your __________ is placed. 
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SESSION 4: SET PAGE BREAKS 

RELEVANT KNOWLEDGE 

To print a worksheet with the exact number of pages that you want, you can adjust 

the page breaks in the worksheet before printing it. This feature is very useful 

especially when printing huge sheets. You can use the Page Break view to see how 

other changes (e.g. changing row height / column width) affect the automatic page 

breaks. 

In this exercise you will learn how to set page breaks in the spreadsheet. 

Open a new spread sheet and create the sheet below. On the View tab, in the 

Workbook Views group, click Page Break Preview. 

Figure 16 

Now to set the page break do the following. 

	 To insert a vertical page break, select the row below where you want to insert 

the page break. To insert a horizontal page break, select the column to the 

right of where you want to insert the page break. 

	 Click on Breaks down arrow under Page Setup group in the Page Layout tab. A 

dropdown appears as shown below. 

Figure 17 
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 Click on Insert Page Break option. The spread sheet will be displayed as shown 

below. The content you have typed comes in the first page and you can print it. 

 To move a page break, simply drag the page break to the desired location. 

Figure 18 

Note: You can also remove the page breaks by clicking the Remove Page Break option 

in Breaks drop down list. 

To return to Normal view after you finish working with the page breaks, click Normal 

in the Workbook Views group under the View tab. 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Set, move and delete page breaks 

2. Create the worksheet given below. Calculate the closing balance. Add 10 

more items to the list and set page breaks for printing. Move page breaks if 

contents do not fit onto one page. Save this file to be used in the following 

exercise with the name items_{your name}. 
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ASSESSMENT 

Fill in the blanks 

1. 	To insert a _________ page break, select the row below where you want 

to insert the page break. 

2. 	To insert a ____________ page break, select the column to the right of 

where you want to insert the page break. 

3. 	The Breaks option is available under______________ group in the Page 

Layout tab. 

4. 	To return to Normal view after you finish working with the page breaks, 

you need to click _____________ in the _____________ group under the 

View tab. 
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SESSION 5: SET PAGE LAYOUT 

If you have a worksheet that contains a huge amount of data with many charts and you 

want a professional looking printout, what would you do? Spread sheet software 

provides various page layout options for organizing pages using the Page Layout option. 

In this exercise, you will learn how to set the page layout options in the spread sheet 

application. Open a new spread sheet. 

To set the page layout options, do the following: 

	 Click on Page Layout option under Workbook Views group on View tab. The 

spreadsheet will be displayed as shown below. You can set the 

o	 Margins 

o	 Orientation 

o	 Page headers and footers 

o	 Hide or display grid lines 

o	 Size of the page 

o	 Define the print area 

o	 Specify the background 

Figure 19 

	 Click on Margins option under Page Setup group, a dropdown list appears as 

shown in figure 20. 

Figure 20 
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	 You can either select anyone of the predefined margin option available or else 

you can define your own margin settings by clicking Custom Margins.. option. 

A dialog box appears. 

Figure 21 

	 You can set the margin values manually from the options available under the 

dialog box. 

	 You can set the orientation of the page to either Portrait or Landscape by 

clicking the Orientation option under Page Setup group in the Page Layout 

tab. 

	 You can set the size of the page by clicking the Size option under Page Setup 

group in the Page Layout tab. 

	 You can specify the area to be printed by selecting the area and then clicking 

Print Area option under Page Setup group in the Page Layout tab. A drop 

down list appears as shown below. 

Figure 22 

 

 

Click on Set Print Area to set the selected to get printed. You can also clear 

the print area by clicking the Clear Print Area option. 

You can specify a background for your sheet using the Background option under 

Page Setup in the Page Layout tab. 

EXERCISE 

Perform the following activity till you are confident: 


S.No. Activity 

1. 
Reopen the worksheet created in the previous exercise named 

items_{your name}. Modify the margins, view the document using 
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print preview and observe the changes 

ASSESSMENT 

Fill in the blanks: 

1. 	Spread sheet software provides various page layout options for 


organizing pages using the _____________ View. 


2. 	Margins option is available under______________ group in the 


_____________ tab. 


3. 	Two types of page orientation are __________________ & 

_______________. 
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SESSION 6: MANAGE WORKBOOK VIEWS 

RELEVANT KNOWLEDGE 

Spread sheet offers the users with variable views for the purpose of viewing the 

outcome of the sheet while printing. 

There are five types of views available in the spreadsheet. 

 Normal 


 Page Layout 

 Page Break Preview 


 Custom Views 

 Full Screen 


You can select one of the above said views by clicking the appropriate option under 

Workbook Views in the View tab. 

Figure 23 

Normal View: The default view of the spreadsheet application is the Normal. It’s a 
collection of cells arranged in the work area. 

Page Layout: You can select the Page Layout view in order to quickly fine tune a 

worksheet that contains many charts or huge amounts of data and achieve professional 

looking results. 

Page Break Preview: This option is similar to the Page Layout option except you can 

set the area that is to be set as a page after inserting page break. 

Custom Views: If you would like to view selected areas of a document , you can use 

the custom view option. For example, if you would like to point out certain row and 

column, you can add that to the Custom view. 

Full Screen: Selecting this option makes the workbook cover the entire screen. All tabs 

are hidden from view. To get back the tabs, click on File> Restore. 

Additionally, in spreadsheet, you can open multiple windows that display the current 

spreadsheet and then arrange those windows in a variety of ways. You can also open 

and arrange multiple workbook windows. 

To open a second instance of a workbook in a separate window: 

 Click the New Window button on the View tab, in the Window group. 
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To arrange multiple program windows: 

 Click Arrange All button in the Window group. An Arrange Windows dialog 

box appears. 

 Click either Tiled, Horizontal, Vertical, or Cascade options. 

 To include only windows displaying views of the current workbook, select the 

Windows of active workbook check box. 

 Click OK. 

. 

Figure 24 

EXERCISE 

Perform the following activities till you are confident: 

S.No. Activities 

1. Reopen the worksheets created in the exercises SS 2 named Marks_{your 

name}, SS3 named expenses_{your name} and SS 4 named items_{your 

name} Using the commands in the Window group on the View menu, tile the 

three windows, and then arrange them so that they overlap. Move each 

window separately and observe what happens in the others. Try the Cascade 

and Tile options too 

2. Use the New Window command to open a second instance of one of the 

workbooks. Then arrange only the two windows of the active workbook 

horizontally 

ASSESSMENT 

Fill in the blanks 

1. 	Different types of views are available under _______________ in the 
View tab. 

2. 	The five types of views available are ________ , ______, 

______________, ______________ & _________________________. 

3. 	 The ________________ helps you to view a selected area of a workbook. 
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SESSION 7: APPLY CELL AND RANGE NAMES 

RELEVANT KNOWLEDGE 

You can assign names to cells in a worksheet and use it for quickly locating specific 

cells by entering the names. This could be useful when working with large spread 

sheets. For example, if you have a lengthy list of groceries and prices, you can use 

names to quickly locate and find total pricing of fruits from the entire list. 

In this exercise, you will learn to work with cell and range names. 

Open a new spreadsheet and enter the following (figure below): 

Figure 25 

Now to apply range names, do the following: 

	 Select the cost against the cells that have Apple, Banana, Cherry, Grape, 

Guava, Mango, Pineapple values (Keep the Ctrl key pressed and click on the 

cells – you will be able to select selective cells together!). Right click and 
select Name a Range…. Alternatively, you can select Define Name under 

Defines Names group in the Formulas tab. 

	 A New Name dialog box appears prompting to enter a name. Enter Fruits in the 

Name field and click OK (figure below). 
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Figure 26 

 Select the cost against the cells that have Cabbage, 

Cucumber, Ginger, Potato, Pumpkin, Spinach, Tomato 

define the name Vegetables for this group. 

Cauliflower, Chilli, 

values. Right click 

Figure 27 

If you would like to calculate the total cost of fruits from the list, 

 Select an empty cell 

 Type Total Cost of Fruits and in the adjacent cell, Type =SUM(Fruits) and press 

Enter. 

Notice the total cost of all items named as Fruits is displayed. 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Apply names to cells and cell ranges and use them in formulae 

2. Using the worksheet created in this exercise, calculate 

Vegetables. Save the workbook as Grocery_{your name}. 

the cost of 
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ASSESSMENT 

Fill in the blanks: 

1. 	 Assigning names to cells in a worksheet help you to _________________ specific 

cells. 

2. 	 The Define Name option is available under _________________ group in the 

________ tab. 
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1 Name January February March April May June 

2 House Rent 2500 2550 2550 3000 3500 3600 

3 Electric Bill 700 750 800 850 900 625 

4 Grocery Expenses 1000 1200 950 850 1500 1250 

5 Trave lling Expenses 500 600 750 680 1000 950 

6 Phone/Mobile Bill 400 500 350 600 sooQ! 
7 

8 

f f 9 

SESSION 1: CREATE MODIFY AND FORMAT CHARTS 

RELEVANT KNOWLEDGE 

A chart is a graphical representation of data, in which the data is represented by 

symbols, such as bars in a bar chart, lines in a line chart, or slices in a pie chart. A 

chart can represent tabular numeric data, functions or some kinds of qualitative 

structures. 

A Spread sheet enables you to create, modify and format charts based on the data 

given in the spread sheet. In this exercise you will learn how to create, modify and 

format chart using the spreadsheet. 

Reopen the worksheet expenses_{your name}. 

Figure 28 

Now to create charts do the following. 

 Select all the expenses data. 

 Click on the chart type that you want from Charts group under the Insert tab. 


 After selecting the chart type the spread sheet will be displayed as shown 

below. 
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Figure 29 

	 You can modify the chart values by making necessary modifications in the data 

table. 

Expenses 


Phone / Mobile Bill 

Travelling Expenses 

Grocery Expenses 

Electric Bill 

House Rent 

Expenses per month 

8000 

7000 

6000 

5000 

4000 

3000 

2000 

1000 

0 

Figure 30 

Chart has many elements; however, only some of the elements are displayed by 

default. Following is an description of the elements used in the above chart: 

1. 	 Chart Area of the Chart 
2. 	 Plot Area of the Chart 
3. 	 Data Points that are plotted in the chart 
4. 	 Horizontal and Vertical Axis in the chart 
5. 	 Legend of the chart 
6. 	 Chart and Axis Title used in the chart 

30 



® ") · 

Home 

Change, SaveAs 
Chart Type Template 

Type 

lnmt Page Layout 

Dab 

Boot:3-Microsofltml Chart Tools 

Formulas Data Rf'li.ew Design Layout 

Chart Layouts 

F01mat 

ChartSfytes 

Move­
Chart 

location 

- " X 

@ - " X 

7. Data Label for identifying details of data point in the chart 

Note: Once you insert a chart in the spreadsheet three additional tabs are available on 

the Ribbon namely Design, Layout and Format. You can edit the chart, its design, 

layout and formatting options using the three tabs available. You can change the chart 

type, chart options etc. in the Design tab and can give the titles etc. in the Layout tab 

and set the borders, colors and size of the option under Format tab. 

Figure 31 

Choosing the right type of chart is very important. Different charts display data in very 

different ways. Using the best chart type and format helps you to display data visually 

in the most meaningful way. 

Bar charts: A bar chart (horizontal bars) emphasizes the comparison between items at 

a fixed period of time. This chart type also includes cylinder, cone, and pyramid 

subtypes. 

Column charts: A column chart, unlike a bar chart to which it is often compared, 

emphasizes variation over a period of time. This chart type also includes cylinder, 

cone, and pyramid subtypes 

Line charts: A line chart shows the relationship of the changes in the data over a 

period of time. 

Pie charts: Pie charts contain just one chart data series. A pie chart shows the 

relationship of the parts to the whole. 

Area charts: An area chart shows the relative importance of values over time. 

XY (Scatter) charts: Scatter charts are useful for showing a correlation among the data 

points that may not be easy to see from data alone. 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Create a chart 

2. Create a worksheet using the sales data given below: 

31 



r A I B, I C I D I E 

1 Location January April July Octobe r 

2 Acapuko 10 5, 20.8 145, 

3 Amsterdam 69 53 76 74 

4 Anchorage 17 13 4 2.5 5,2 

5 Da llas 48 87.5, 6 2 118 

6 fi la.sgow 110 50 61 112 

17 Madrid 39 48 11 5,3 

8 N ewYork 99 :mo 115 86 

9 Tokyo 101 121 189 172. 

10 Toronto 55.2 65.4 71 63.S. 

3. Create bar and line charts using this data. Enhance the design of your chart 
to make it more presentable. 

4. Calculate the total sales for each city. Create a pie chart representing the 

total sales of each city. 

ASSESSMENT 

I. Fill in the blanks: 

1. 	 A chart is a ______________ ______________ of data, in which the data is 

represented by symbols, such as ____ in a bar chart, _____ in a line chart, or 

______ in a pie chart. 

2. 	 The three tabs that are available after inserting the chart in the spreadsheet 

are _____________ , ____________________ & _________ _______________. 

II. Answer the following: 

1. 	 List seven chart elements. 

2. 	 List five chart types available in spreadsheet. 
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SESSION 2: SORT AND FILTER DATA 

RELEVANT KNOWLEDGE 

Sort is a feature that helps you arrange the selected data either in an ascending or 

descending order. Filter is a feature used for extracting particular data using some 

conditions. Spread sheet offers both these features for sorting and filtering data in the 

spreadsheet. 

Open a new spreadsheet and enter the following data: 

Figure 32 

Now to sort or filter the data do the following: 

	 Select the data to be sorted and then click on Sort option under Sort & Filter 

group in the Data tab. A dialog box appears as shown below. 

Figure 33 

	 You need to specify on what basis you are going to sort the data in the Sort by 

field and select the order that is ascending and descending and then click OK. 

For example, if you wanted to sort the data in Sales 2008, you would select the 

relevant detail in the Sort by list and click OK. The spreadsheet would be 

displayed as shown below. You can notice that the data has been sorted as per 

the data in 2008 and also that values in the Sales 2008 field are arranged in 

ascending order that is from smallest to largest. 

Figure 34 
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To filter data, do the following: 

	 Click the Filter option available under Sort & Filter group in the Data tab. 

Before applying a filter you have to select the data along with the header as 

shown below. 

Figure 35 

	 Once you click on filter, the headers will be displayed with a down arrow as 

shown below. 

Figure 36 

If you want to filter data that is greater than 75 in the Sales 2009 do the following. 

	 Click the down arrow available under Sales 2009 header, a dropdown list 

appears as shown below. 

Figure 37 

	 You can specify the filter by selecting the available values in the list. 

	 You can also sort the filtered data by selecting Sort Smallest to Largest or Sort 

Largest to Smallest option available in the dropdown list. 

	 Click on Number Filters option under the dropdown list, once you click the 

following submenu appears. 
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Figure 38 

	 Here you can select the condition that you want to specify for the data in the 

list, If you select Greater Than.. option the following dialog box appears. 

Figure 39 

	 Specify the value that you want in the value box, (here it is 75) and click OK. 

The spreadsheet will be displayed as shown below. Notice that only data 

greater than 75 is displayed under the Sales 2009. 

Figure 40 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Sort a dataset in the required order 

2. Filter data on specified criteria 
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3. Create a worksheet with the data given below. Create totals. Calculate 

percentages. Use this to sort data subject wise and also rank-wise. Save this 

file as Student_{your name}. 

Students Test 1 Test 2 Test 3 Test 4 

Shilpa 50 65 57 77 

Sheela 98 99 78 58 

Avikal 76 78 98 96 

Vaibhav 87 76 92 67 

Abhijeet 56 88 66 88 

Surbhi 68 85 92 99 

Kavita 99 58 78 89 

Tanishk 79 78 56 78 

Vishwank 59 81 78 67 

ASSESSMENT 

Fill in the blanks: 

1. 	 Sort helps you arrange the selected data either in an__________ or 

___________ order. 

2. 	 Using filter you can extract data based on _________. 

3. 	 Sort option is available in _______________________ group under the Data tab. 

4. 	 Filter option is available in _______________________ group under the Data 

tab. 
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A I B C I D I E I f G H 

1 Name Janua~ feorua~ Maren April May June 

2 House Rent 7 2500 2550 2550 ~000 ~500 ~600 

~ Electric Bill 700 750 800 850 900 625 

4 Groce~ Expenses 1000 1200 950 850 1500 1250 

5 Travelling Expenses 500 600 750 680 1000 950 

6 Pnone/Mooile Pnone 400 500 ~50 600 800• 
7 

SESSION 10: CALCULATE DATA ACROSS WORKSHEETS 

RELEVANT KNOWLEDGE 

Suppose you were working at the head office maintaining had data for six regions, and 

you use exactly the same worksheet layout and labels to track the average sales of 

each region over the previous quarter. Each sheet contains headings by region (such as 

Region01, Region02 ….. Region06), and in cell H15 on each sheet, the calculated total 
sales for the quarter appear. If you want to obtain the average sales over the quarter, 

what would you do? 

In this exercise you will learn how to perform calculations on data across different 

worksheets. 

Open a new spreadsheet. Name sheet 1 as year1 and type the following data. 

Figure 41 

Now to calculate the data across worksheets do the following. 

 Go to sheet 2, name it year2 sheet, and insert the same data in the Sheet2 for 

the next year. 

 Go to sheet 2, name it Totals, and insert the same labels. 

 Type the sum formula in cell B2, =sum( , while the parenthesis is opened go to 

year1 sheet and go to year2 sheet and press Enter. Repeat the same step to 

calculate sum for other expenses. Note the way the range is specified 

(sheetname!cellnumber). 
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Figure 42 

To answer the question raised earlier, you could create a new sheet, called Quarter 

Summary. To find the average, enter the following formula in one of the cells in the 

Summary sheet: =AVERAGE(Region01: Region06!H15) 

Spreadsheet calculates the average for all values stored in H15 on all sheets in the 

range Region01:Region06. If you move the Region06 sheet between Region04 and 

Region05, the software will adjust the calculation to include the sheets for Regions01, 

02, 03, 04, and 06; Region05 will be omitted. Similarly, if you delete or add a sheet 

anywhere between Region01 and Region06, the software will include all the sheets 

located within the range in its calculation. 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Make calculations across worksheets 

2. Create 2 worksheets populated with subject and marks for 1st and 2nd 

terms. Create another worksheet called Average and calculate the average 

of marks for all subjects. 
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SESSION 11: USING MULTIPLE WORKBOOKS AND LINKING CELLS 

RELEVANT KNOWLEDGE 

Spreadsheet also allows you to link the cells from various worksheets and from various 

spread sheets to summarize data from several sources. In this manner, you can create 

formulas that span different sources and make calculations using a combination of 

local and linked information. You can link data from other spreadsheets and keep the 

information up to date without editing multiple locations every time the data changes. 

For example, you can display data from multiple departments for an overview of 

details without sharing information between sources. 

In this exercise you will learn how to link cells from different spreadsheet applications. 

Open a new spread sheet and enter the following data: 

Figure 43 

To link cells from different worksheet do the following: 

	 Open a new spreadsheet workbook. 

	 Type some formula, for example sum formula in any cell =sum(, while the 

parenthesis is opened, click on Switch Windows option under Window group in the 

View tab. A dropdown list appears with the active workbook names. 

Figure 44 

	 Click on Book1 to select the earlier spreadsheet you had created and select the cells 
A2:D2. 
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Figure 45 

	 Press Enter. You are back on the second spreadsheet. The cell where you were 
entering the formula has the total of the values in the first spreadsheet!. Note the 

way the software gives the cell reference. If you update any values in the first 

spreadsheet, automatically the sum value in the second spreadsheet is updated! Try 

this out. 

Figure 46 

EXERCISE 

Perform the following activities till you are confident: 


S.No. Activities 

1. Link cells and make calculations across workbooks 

ASSESSMENT 

Fill in the blanks: 

1. 	 Switch Windows option is available in _____________ group under the View tab. 

2. 	 Linking cells from different _______ / __________ helps you to summarize data 

from different sources. 

3. 	 Linking data helps you help to keep information __________ without editing at 

multiple locations. 
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1 Name January February March April May June 

2 House Rent 2500 2550 2550 3000 3500 3600 

3 Electric Bill 700 750 800 850 900 625 

4 Grocery Expenses 1000 1200 950 850 1500 1250 

5 Travelling Expenses 500 600 750 680 1000 950 

6 Phone/Mobile Bill 400 500 350 600 800• 
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SESSION 12: SHARING WORKSHEET DATA 

RELEVANT KNOWLEDGE 

In most office settings, there is a shared drive where teams can store common files for 

everyone to use. This usually leads to sighting of the message: “The document [file 
name] is locked for editing by another user. To open a read-only copy of this 

document, click“!! This message appears because someone else already has the file 
open. Sometimes however, it is necessary to have multiple people working on a file at 

the same time. This can be to either speed up data entry or simply make things easier 

for collaboration purposes. 

Spreadsheet software allows the user to share the workbook and place it in the 

network location where several users can access it simultaneously. In this exercise, 

you will learn how to share a worksheet. 

Open a new spreadsheet and type the following. 

Figure 47 

Now to share the spreadsheet do the following. 

 Click on Share workbook option under Changes group in the Review tab. 

 A dialog box appears as shown below. 
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Figure 48 

 Check the option Allow changes by more than one user at the same time. 

This also allows workbook merging. 

 Click OK. 

Note: Most spreadsheet software automatically turn off some features in shared 

workbooks. This is to simplify the workbook since multiple people can be working on 

the file at the same time. For example, shared workbooks don’t allow merging cells, 
conditional formatting, or inserting pictures/graphs/etc. 

EXERCISE 

Perform the following activity till you are confident: 


S.No. Activity 

1. Share worksheet data with other users. 

ASSESSMENT 

Fill in the blanks: 

1. 	Share Workbook option is available in ___________ group under the 

Review tab. 

2. 	Shared workbooks don’t allow __________________-, ________________ 

& inserting _________or ________. 
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